代々木で働く19歳エンジニアのブログ

思ったこととか、技術的なこと書きます。

Gemfileのバージョン指定の書き方

  • 1.0.0 バージョンを固定。
  • >= 1.0.0 1.0.0以上のバージョンが必要
  • >= 1.0.0, < 2.0.0 1.0.0以上、2.0.0未満のバージョンが必要、ex) 1.x.x
  • ~> 1.0.0 1.0.0以上で利用可能で、1.0.9などは問題なく、1.1にバージョンが上がると利用不可 ex) 1.0.x

reference from